System Requirements

Compatible with:  |    |    |  

PPS Express

  • Accessible via any up to date device with access to a web browser – please check the device settings to ensure the latest operating system is installed.
  • An up-to-date web browser – please check the app store or installation settings of the device to ensure the latest version is installed.
  • Active and stable internet connection (wired, wireless, 3/4G).

PPS

Our online solution has the following minimum requirements:

  • Windows 11, Windows 10 Pro, Windows 8.1 Pro – to support version 10.8 + of the Windows RDP client.
  • macOS – Must be able to run the latest version of the Microsoft Remote Desktop app. Find compatibility details here.
  • iOS 13.0 or later – Must be able to run the latest version of the Microsoft Remote Desktop app. Find compatibility details here.
  • Android/ChromeOS – Must be able to run the latest version of the Microsoft Remote Desktop app, available here.
  • All Operating Systems ready to support TLS 1.2
  • A stable and consistent network connection. (Wired, wireless, 3/4G)
  • You will need to confirm the following IP addresses are open:
    • 198.244.193.50
    • 5.135.41.11
    • 5.135.41.12
    • Gateway IP – 51.255.232.196
  • You will also need to confirm that the following port is open: Port 443
  • Some functionality will be limited by device type/app support. Printing from PPS Hosted and saving to & from local drives is available only in full Windows and macOS.
  • To print: Must have the latest version of TS Print
  • To scan: Must have the latest version of TS Scan and a scanner with full and up to date TWAIN drivers.